Naming Fail

I’ve no idea what went wrong here. Nice, clean code. Javadoc is present. Completely useless.

/**
* Interface for switchable artefacts
*/
public interface Switchable
{
        /**
        * set the component on or off
        */
        public void setOnOrOff(boolean value);
        
        /**
        * returns if the artefact is on or off
        */
        public boolean getOnOrOff();
}